Babboe Display

Beiträge
8
Hallo!
Ich lese hier schon eine Weile mit und habe schon viele nützliche Infos gefunden. Danke schonmal an Euch alle dafür :)

Grade habe ich ein Problem mit unserem Babboe Dog-E: Nachdem es ein paar Tage gefroren hatte ließ sich der E-Antrieb irgendwann nicht mehr einschalten. Nachdem ich mich durch die diversen Verklebungen des Displaygehäuses (C500) gepopelt hatte hat sich meine Vermutung bestätigt, dass Wasser in das Gehäuse eingedrungen war. Ein auf der Rückseite des Gehäuses angebrachter Klebestreifen, wohlgemerkt aus einem Material das anscheinend explizit Wasser aufsaugen soll, hat mit diesem aufgesaugten Wasser die darüberliegenden Kondensatoren kurzgeschlossen.
Nachdem ich die defekten Kondensatoren entfernt habe funktioniert das Display erfreulicherweise wieder, was die Alltagswege wieder sehr viel angenehmer macht. Allerdings ist es mir nicht gelungen das Gehäuse so zu öffenen dass es wieder dicht bekommen zu wäre, außerdem ist die Membran eines Tasters defekt (ich vermute dass das Wasser dort initial in das Gehäuse reinkam).
Ich dachte, na gut, bestell ich eben einfach ein neues Display, das hat allerdings 18 Wochen o_O Lieferzeit (Nachfolgemodell G600 statt C500). Nachfrage bei einer autorisierten Babboe Werkstatt ergab ähnliche Lieferzeiten. Ich hab kein gutes Gefühl mich noch so lange auf das Provisorium zu verlassen.

Jetzt habe ich folgende Ideen das Problem zu lösen:

1. ReReRepair: weiteres (defektes) Display besorgen, nach (hoffentlich) erfolgreichem Reparaturversuch in neues, dichtes Gehäuse einbauen. Display am Fahrrad austauschen, und das gleiche mit dem aktuellen Provisorium machen, ins Regal legen und vorbereitet sein, wenn es wieder kaputt geht, dann von vorn.

2. Nachbau: Kommunikationsinterface und -protokoll des Displays ermitteln und auf eigener Hardware umsetzen. Die wenigen Infos die ich bisher dazu gefunden habe deuten darauf hin dass zumindest ein Teil der Kommunikation über RS232 läuft.

Nun zu meinen Fragen:
  • Hat jemand kompatible (C500/G600), ungenutzte Displays herumliegen, die gegen Porto + Aufwandsentschädigung abzugeben wären?
  • Kennt jemand kompatible, lieferbare Displays? Das von Yosepower scheint auf den ersten Blick die gleich Hardware zu haben, zumindest der Stecker scheint aber schonmal unterschiedlich zu sein. Hat da jemand schon Erfahrungen gemacht?
  • Weiß jemand wie genau die Steckverbinder heißen, die für die Kommunikationsverbindungen am ibo-C09S Controller genutzt werden und im Idealfall wo man diese beziehen kann? In der Spec werden diese nur als EM6 bezeichnet (theoretisch würden auch abgeschnittene Kabel reichen um einen Zwischenstecker zu bauen, mit dem man die Kommunikation mitsniffen kann)
  • Hat jemand irgendwelche Infos zum Kommunikationsprotokoll zwischen Display und Controller?
Vielen Dank schonmal fürs Lesen, bin gespannt auf Eure Rückmeldungen :giggle:
 
Willkommen im Forum oder schoen das du dich reintraust... :)
für die Kommunikationsverbindungen am ibo-C09S Controller genutzt werden und im Idealfall wo man diese beziehen kann? In der Spec werden diese nur als EM6 bezeichnet
Foto ist immer hilfreich und hilft enorm ;)

Ist das ein Koaxverbinder?
Wenn ja dann guckst du am Besten bei Audioverbindern - da gibts die GX in vielfaeltigster Ausfuehrung.
Beispiel
 
Es ist ein Rundstecker mit Verschraubung. Am ehesten würde ich denken dass es ein Sensorstecker M6, 6pol ist. Da die ganze Steckerei immer nicht ganz günstig ist wollt ich nur mal nachfragen ob jemand schon Erfahrungswerte hat. Nicht passende Stecker hab ich nämlich schon genug :)

Die aus dem Link sind ähnlich, aber viel größer denke ich. Wie gesagt, M6 könnte von der Größe her passen.

Morgen mach ich ein Foto und häng es rein.
 
Ach siehste, ich dachte immer das wäre die Gewindegröße, also M12, M16, usw. :unsure:

Ich hab oben jedenfalls Quatsch geschrieben, ich meinte M8 Sensor Stecker. Die bekommt man nur in 6pin gar nicht so gut.
 
Update:
Ich warte gerade auf die Kabelenden mit angegossenen Steckern. Die haben allerdings ne recht lange Lieferzeit (Ali ohne express).

Hier Bilder vom Stecker, USB-C zum Größenvergleich:
2024-02-16-08-22-37-625.jpg

2024-02-16-08-22-32-271.jpg
2024-02-16-08-22-20-919.jpg

Hab inzwischen Teile von Babboe erhalten, allerdings nur das Verlängerungskabel, das man anscheinend für das neue Displaymodell braucht. Nachdem Babboe jetzt zumindest kurzzeitig den Verkauf von Lastenrädern einstellen muss geht das mit dem Display vielleicht ja jetzt ein bisschen schneller

Mein Plan ist aktuell einen (möglichst universell einsetzbaren) UART Sniffer zu bauen, den man im Normalbetrieb zwischen Display und Controller hängt. So könnte man dann für verschiedene Display/Controllerkonfigurationen das UART Protokoll dokumentieren. Für mich natürlich erstmal für meine Kombination interessant.

Solange das Thema offen bleibt halte ich Euch gern über den aktuellen Stand auf dem Laufenden.
 
Update:
Ich warte gerade auf die Kabelenden mit angegossenen Steckern. Die haben allerdings ne recht lange Lieferzeit (Ali ohne express).

Hier Bilder vom Stecker, USB-C zum Größenvergleich:Anhang anzeigen 49060
Anhang anzeigen 49061Anhang anzeigen 49062
Hab inzwischen Teile von Babboe erhalten, allerdings nur das Verlängerungskabel, das man anscheinend für das neue Displaymodell braucht. Nachdem Babboe jetzt zumindest kurzzeitig den Verkauf von Lastenrädern einstellen muss geht das mit dem Display vielleicht ja jetzt ein bisschen schneller

Mein Plan ist aktuell einen (möglichst universell einsetzbaren) UART Sniffer zu bauen, den man im Normalbetrieb zwischen Display und Controller hängt. So könnte man dann für verschiedene Display/Controllerkonfigurationen das UART Protokoll dokumentieren. Für mich natürlich erstmal für meine Kombination interessant.

Solange das Thema offen bleibt halte ich Euch gern über den aktuellen Stand auf dem Laufenden.
Hallo!
Ich lese hier schon eine Weile mit und habe schon viele nützliche Infos gefunden. Danke schonmal an Euch alle dafür :)

Grade habe ich ein Problem mit unserem Babboe Dog-E: Nachdem es ein paar Tage gefroren hatte ließ sich der E-Antrieb irgendwann nicht mehr einschalten. Nachdem ich mich durch die diversen Verklebungen des Displaygehäuses (C500) gepopelt hatte hat sich meine Vermutung bestätigt, dass Wasser in das Gehäuse eingedrungen war. Ein auf der Rückseite des Gehäuses angebrachter Klebestreifen, wohlgemerkt aus einem Material das anscheinend explizit Wasser aufsaugen soll, hat mit diesem aufgesaugten Wasser die darüberliegenden Kondensatoren kurzgeschlossen.
Nachdem ich die defekten Kondensatoren entfernt habe funktioniert das Display erfreulicherweise wieder, was die Alltagswege wieder sehr viel angenehmer macht. Allerdings ist es mir nicht gelungen das Gehäuse so zu öffenen dass es wieder dicht bekommen zu wäre, außerdem ist die Membran eines Tasters defekt (ich vermute dass das Wasser dort initial in das Gehäuse reinkam).
Ich dachte, na gut, bestell ich eben einfach ein neues Display, das hat allerdings 18 Wochen o_O Lieferzeit (Nachfolgemodell G600 statt C500). Nachfrage bei einer autorisierten Babboe Werkstatt ergab ähnliche Lieferzeiten. Ich hab kein gutes Gefühl mich noch so lange auf das Provisorium zu verlassen.

Jetzt habe ich folgende Ideen das Problem zu lösen:

1. ReReRepair: weiteres (defektes) Display besorgen, nach (hoffentlich) erfolgreichem Reparaturversuch in neues, dichtes Gehäuse einbauen. Display am Fahrrad austauschen, und das gleiche mit dem aktuellen Provisorium machen, ins Regal legen und vorbereitet sein, wenn es wieder kaputt geht, dann von vorn.

2. Nachbau: Kommunikationsinterface und -protokoll des Displays ermitteln und auf eigener Hardware umsetzen. Die wenigen Infos die ich bisher dazu gefunden habe deuten darauf hin dass zumindest ein Teil der Kommunikation über RS232 läuft.

Nun zu meinen Fragen:
  • Hat jemand kompatible (C500/G600), ungenutzte Displays herumliegen, die gegen Porto + Aufwandsentschädigung abzugeben wären?
  • Kennt jemand kompatible, lieferbare Displays? Das von Yosepower scheint auf den ersten Blick die gleich Hardware zu haben, zumindest der Stecker scheint aber schonmal unterschiedlich zu sein. Hat da jemand schon Erfahrungen gemacht?
  • Weiß jemand wie genau die Steckverbinder heißen, die für die Kommunikationsverbindungen am ibo-C09S Controller genutzt werden und im Idealfall wo man diese beziehen kann? In der Spec werden diese nur als EM6 bezeichnet (theoretisch würden auch abgeschnittene Kabel reichen um einen Zwischenstecker zu bauen, mit dem man die Kommunikation mitsniffen kann)
  • Hat jemand irgendwelche Infos zum Kommunikationsprotokoll zwischen Display und Controller?
Vielen Dank schonmal fürs Lesen, bin gespannt auf Eure Rückmeldungen :giggle:
Hi!

Ich hab noch ein defektes C500. Ließ sich nicht mehr einschalten. Für Porto und symbolische 10€ kann ich es dir gerne zusenden. Die Display Situation ist echt grenzwertig bei Babboe.
Gruß Rocco
 
Update:
Ich warte gerade auf die Kabelenden mit angegossenen Steckern. Die haben allerdings ne recht lange Lieferzeit (Ali ohne express).

Hier Bilder vom Stecker, USB-C zum Größenvergleich:Anhang anzeigen 49060
Anhang anzeigen 49061Anhang anzeigen 49062
Hab inzwischen Teile von Babboe erhalten, allerdings nur das Verlängerungskabel, das man anscheinend für das neue Displaymodell braucht. Nachdem Babboe jetzt zumindest kurzzeitig den Verkauf von Lastenrädern einstellen muss geht das mit dem Display vielleicht ja jetzt ein bisschen schneller

Mein Plan ist aktuell einen (möglichst universell einsetzbaren) UART Sniffer zu bauen, den man im Normalbetrieb zwischen Display und Controller hängt. So könnte man dann für verschiedene Display/Controllerkonfigurationen das UART Protokoll dokumentieren. Für mich natürlich erstmal für meine Kombination interessant.

Solange das Thema offen bleibt halte ich Euch gern über den aktuellen Stand auf dem Laufenden.
Hab auch schon einige Displays gesehen, die vom Gehäuse und LCD Anzeige her die gleichen sind. Stecker ist aber leider anders. Wenn du eine Lösung findest, wäre das super. Hab jetzt scheinbar meinen zweiten Displayschaden und nur mit Glück noch ein G600 aufgetrieben.
 
Hi Rocco,
wegen des defekten Displays schreib ich Dir ne PN.

Die Stecker sind inzwischen angekommen, weichen aber in der Pinanordnung leicht ab und passen deswegen nicht

Ich hatte ja die Hoffnung dass sie jetzt wenigstens die Ersatzteile schnell ausliefern, wenn sie schon keine Fahrräder verkaufen dürfen. Hab meines aber noch nicht erhalten...
 
Hi Rocco,
wegen des defekten Displays schreib ich Dir ne PN.

Die Stecker sind inzwischen angekommen, weichen aber in der Pinanordnung leicht ab und passen deswegen nicht

Ich hatte ja die Hoffnung dass sie jetzt wenigstens die Ersatzteile schnell ausliefern, wenn sie schon keine Fahrräder verkaufen dürfen. Hab meines aber noch nicht erhalten...
aktuell steht bei allen Displays bei Babboe "Leider vorübergehend nicht verfügbar". Ich rechne nicht in nächster Zeit mit einer Lieferung. Das Kabel hab ich auch bekommen. Saftladen!
Wenn du ein G600 Display noch brauchst, hier gibts noch welche!
Hab gestern angefragt und es liegen noch genug auf Lager. Ist auch der einzige Laden im Inet der noch was hat. Hatte dort schon mal bestellt.
 
Moin zusammen,

auch ich war von einem kaputten Display betroffen und konnte es retten. Meine Erkenntnisse, die ich dabei gewonnen habe, möchte ich euch hier kurz mitteilen.

Das Problem bei mir war, dass die Set-Taste einen Dauerkontakt hatte und dadurch die Schiebehilfe aktiv war. Andere Tasten konnte ich nicht mehr drücken. Da man durch die Displayabdeckung Wasser im Display gesehen hat, war die Ursache sehr offensichtlich. Ich war schonmal froh, dass sich das Display überhaupt hat einschalten lassen. Also sofort Akku abgenommen, bevor noch ein schlimmerer Kurzschluss passiert und das Display abmontiert. Bei meinem Babboe Big-E befand sich der Stecker zwischen Display und Akku innerhalb des Sitzrohres. Also erstmal Kabel Richtung Akku zurückgezogen, Stecker gelöst und dann das Kabel aus dem Rahmen gezogen. Achtung, knotet euch Paracord oder eine stabile Schnur an, damit ihr später das Kabel auch wieder in den Rahmen rein ziehen könnt.

Das Display war gar nicht so einfach zu öffnen. Es gab zwar Schrauben, aber zusätzlich war das Gehäuse verklebt. Hier habe ich vorsichtig mit einem Taschenmesser das Gehäuse ausgehebelt. Hierfür habe ich mir viel viel viel Zeit genommen.

So, nun aber zum interessanteren Teil :)

Auf der Platine steht "C500-TL02" und ist mit 5 Adern angeschlossen:

1712902816168.png


Die 6. Ader des Babboe-Steckers ist einfach bündig abgeknipst:

1712902878799.png


Man sollte sich also relativ einfach ein Adapterkabel bauen können, was den 6-poligen Babboe-Stecker mit dem 5-poligen Stecker des Displays verbindet.

In meinem Fall hat es geholfen, das Display zu trocknen und wieder zusammen zu schrauben. Als Regenschutz habe ich einen durchsichtigen Silikon-Frischhaltedeckel über das Display gestülpt. Sieht doof aus, aber funktioniert. Wir können zumindest wieder elektrisch fahren :)

Viele Grüße
Tatze
 
Hallo Zusammen
Ich habe leider auch ein defektes C500 Display.
Hat jemand die Belegung mittlerweile zu den Yosepower Displays?
Babboe-Stecker 6polig (5 Adern angeschlossen) auf 5 poligen Higo Stecker (Yosepower)

Gruß und Dank
Thorsten
 
Moin
Vielen Dank für den Link, dann werde ich mir mal ein Display bestellen und den Lötkolben heizen.
Werde Erfolg oder Misserfolg hier posten.
 
Falls Du das Gehäuse öffnen möchtest: es hilft enorm die Klebeflächen bzw. das Gehäuse mit einem Fön anzuwärmen. Der Kleber löst sich dann deutlich leichter.

Edit: Bilder angehängt:
Auf dem ersten Bild sieht man wie der geklebte Alurahmen abgeht.
Auf dem zweiten Bild wo das eigentliche Gehäuse aufgeht. Die Kante unter der Scheibe mit den Knöpfen kann man sich sparen, da kommt man nicht an die Platine ran und muss sie dann nur mühsam wieder ankleben.
 

Anhänge

  • 2024-04-25-20-42-36-707.jpg
    2024-04-25-20-42-36-707.jpg
    82,5 KB · Aufrufe: 13
  • 2024-04-25-20-49-59-698.jpg
    2024-04-25-20-49-59-698.jpg
    80,3 KB · Aufrufe: 13
Zuletzt bearbeitet:
Hallo Zusammen,
So mein Ersatz Display ist angekommen. Kabel geschnitten verlötet und siehe da, das Display geht an. *freu*
Aber es kommt Error 9 Kommunikation also schauen ob RX und TX vertauscht (leider nein)
(Die Aderfarben in der Beschreibung des Yosepower C500 sind im Deutschen andere als auf der englischen Beschreibungsseite. Aufgepasst die englischen stimmen)
Also Altes Display nochmals mit zum Messplatz und siehe da wenn ich auf die grüne Ader V+ drauf geben (Weak lock) geht das Alte Display an und gibt mir leider den gleichen Fehler raus (Error 9)
Also mal die Controllerbox öffnen. Und siehe da eine zugegossene Elektronik mit ein 8 Pin Programmieranschluss.
Nächster Schritt für mich also schauen wo bekomme ich eine Controllerbox her.... (Kleinanzeigen und Ebay stehen die Anfragen ;-) )
ibo-CNTR-09S (V1) 33,8V 10A
Bei neuen Erkenntnissen werde ich weiter berichten
Gruß TH-Orsten
 

Anhänge

  • ibo-cntr-09S.JPG
    ibo-cntr-09S.JPG
    40,6 KB · Aufrufe: 20
Moin Zusammen,
Neue Erkenntnisse, zu viele Ersatzteile und ein repariertes Display.
Nach dem ich eine neue Controllereinheit bekommen haben Dank Kleinanzeigen. Stellte sich raus der Fehler bleibt.
Das Yosepower Display bleibt auf Error 9. also mal ein wenig die Elektronik auf dem Display genauer anschauen.
Das Weak Lock Signal ist wohl ein Controller wachauf Signal vom Display. gebe ich dort Batteriespannung drauf geht das Display an und zeigt mir sogar die Aktuelle Akkuladung an. Weiter suchen.
Am Ende waren es korrodierte Durchkontaktierungen vom Taster (Ein/Aus) siehe Bilder. Was ich aber erst beim nachverfolgen der Leiterbahnen raus fand und das Display abgelötet hatte.
Morgen mal ans Rad an bauen und los geht es wieder.
Übrige Controlerbox werde ich wohl wieder bei Kleinanzeigen einsetzten.
 

Anhänge

  • 20240525_071721752_iOS.jpg
    20240525_071721752_iOS.jpg
    270,4 KB · Aufrufe: 9
Moin Thorsten,

super, dass das Display bei dir wieder funktioniert. Habe ich das richtig verstanden, dass du das alte Display wieder repariert hast? Würde das Yosepower Display denn als Ersatz funktionieren?

Viele Grüße,
Tatze
 
Das hat bei meinen alten und neuen Controller immer Error 9 angezeigt. (Kommunikationsfehler) Auch wenn ich RX und TX gedreht habe. Daher bin ich bei meinem alten Display tiefer eingestiegen. Könnt noch mal das Protokoll abfangen, liegt noch alles mein mir offen. Ich Schaumal ob ich morgen dafür Zeit finde.
 
Zurück
Oben Unten